dev-util/clair: 2.1.3 bump
[gentoo.git] / app-cdr / dumpet / dumpet-2.1_p20140601-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs vcs-snapshot
7
8 COMMIT="8f47670dd582c96ad1b6dd3c9b9da0acebded5d8"
9
10 DESCRIPTION="A tool to dump and debug bootable CD-like images"
11 HOMEPAGE="https://github.com/rhboot/dumpet"
12 SRC_URI="https://github.com/rhboot/dumpet/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="test"
18 #Restrict tests since required test file is unavailable
19 RESTRICT="test"
20
21 RDEPEND="dev-libs/libxml2
22         dev-libs/popt"
23 DEPEND="${RDEPEND}
24         virtual/pkgconfig
25         test? ( dev-util/valgrind )"
26
27 src_prepare() {
28         sed -i Makefile \
29                 -e "s/^install : all$/install :/" \
30                 -e "s/^CFLAGS:=/CFLAGS?=/" \
31                 -e "s/^CC:=/CC?=/" \
32                 || die
33         default
34 }
35
36 src_compile() {
37         emake CFLAGS="${CFLAGS}" dumpet
38 }
39
40 pkg_setup() {
41         tc-export CC
42 }