Use https by default
[gentoo.git] / app-cdr / cdrkit / cdrkit-1.1.11-r2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit cmake-utils eutils
7
8 DESCRIPTION="A set of tools for CD/DVD reading and recording, including cdrecord"
9 HOMEPAGE="http://cdrkit.org"
10 SRC_URI="mirror://debian/pool/main/c/${PN}/${PN}_${PV}.orig.tar.gz
11         https://dev.gentoo.org/~ssuominen/${P}-libcdio-paranoia.tar.xz"
12
13 LICENSE="GPL-2 LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~arm-linux ~x86-linux"
16 IUSE="debug hfs unicode"
17
18 RDEPEND="app-arch/bzip2
19         !app-cdr/cdrtools
20         dev-libs/libcdio-paranoia
21         sys-apps/file
22         sys-libs/zlib
23         unicode? ( virtual/libiconv )
24         kernel_linux? ( sys-libs/libcap )"
25 DEPEND="${RDEPEND}
26         hfs? ( sys-apps/file )"
27
28 src_prepare() {
29         epatch \
30                 "${FILESDIR}"/${P}-cmakewarn.patch \
31                 "${WORKDIR}"/patches/${P}-paranoiacdda.patch \
32                 "${WORKDIR}"/patches/${P}-paranoiacdio.patch
33
34         echo '.so wodim.1' > ${T}/cdrecord.1
35         echo '.so genisoimage.1' > ${T}/mkisofs.1
36         echo '.so icedax.1' > ${T}/cdda2wav.1
37         echo '.so readom.1' > ${T}/readcd.1
38 }
39
40 src_install() {
41         cmake-utils_src_install
42
43         dosym wodim /usr/bin/cdrecord
44         dosym genisoimage /usr/bin/mkisofs
45         dosym icedax /usr/bin/cdda2wav
46         dosym readom /usr/bin/readcd
47
48         dodoc ABOUT Changelog FAQ FORK TODO doc/{PORTABILITY,WHY}
49
50         local x
51         for x in genisoimage plattforms wodim icedax; do
52                 docinto ${x}
53                 dodoc doc/${x}/*
54         done
55
56         insinto /etc
57         newins wodim/wodim.dfl wodim.conf
58         newins netscsid/netscsid.dfl netscsid.conf
59
60         insinto /usr/include/scsilib
61         doins include/*.h
62         insinto /usr/include/scsilib/usal
63         doins include/usal/*.h
64         dosym usal /usr/include/scsilib/scg
65
66         doman "${T}"/*.1
67 }