app-benchmarks/sysbench: bump to 1.0.4
[gentoo.git] / app-benchmarks / sysbench / sysbench-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit git-r3
7
8 DESCRIPTION="System performance benchmark"
9 HOMEPAGE="https://github.com/akopytov/sysbench"
10
11 EGIT_REPO_URI="https://github.com/akopytov/sysbench.git"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE="aio mysql postgres test"
17
18 RDEPEND="aio? ( dev-libs/libaio )
19         mysql? ( virtual/libmysqlclient )
20         postgres? ( dev-db/postgresql:= )"
21 DEPEND="${RDEPEND}
22         app-editors/vim-core
23         dev-lang/luajit:=
24         dev-libs/concurrencykit
25         dev-libs/libxslt
26         sys-devel/libtool:=
27         virtual/pkgconfig
28         test? ( dev-util/cram )"
29
30 src_prepare() {
31         default
32
33         # remove bundled libs
34         rm -r third_party/luajit/luajit third_party/concurrency_kit/ck third_party/cram || die
35
36         ./autogen.sh || die
37 }
38
39 src_configure() {
40         local myeconfargs=(
41                 $(use_enable aio aio)
42                 $(use_with mysql mysql)
43                 $(use_with postgres pgsql)
44                 --without-attachsql
45                 --without-drizzle
46                 --without-oracle
47                 --with-system-luajit
48                 --with-system-ck
49         )
50
51         econf "${myeconfargs[@]}"
52 }
53
54 src_test() {
55         emake check test
56 }