41adb494631edbd9337f0a0a43e9d679a45bd237
[gentoo.git] / app-benchmarks / stress / stress-1.0.4-r2.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 DESCRIPTION="A deliberately simple workload generator for POSIX systems"
7 HOMEPAGE="https://people.seas.harvard.edu/~apw/stress"
8 SRC_URI="https://people.seas.harvard.edu/~apw/${PN}/${P}.tar.gz -> ${P}-r1.tar.gz"
9
10 LICENSE="GPL-2+"
11 SLOT="0"
12 KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
13 IUSE="static"
14
15 src_configure() {
16         local myeconfargs=(
17                 $(use_enable static)
18         )
19
20         econf "${myeconfargs[@]}"
21 }