Merge remote-tracking branch 'github/pr/372'.
[gentoo.git] / app-benchmarks / siege / siege-3.1.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 #WANT_AUTOMAKE=1.9
8
9 inherit eutils bash-completion-r1 libtool autotools
10
11 DESCRIPTION="A HTTP regression testing and benchmarking utility"
12 HOMEPAGE="https://www.joedog.org/siege-home/"
13 SRC_URI="http://download.joedog.org/${PN}/${P}.tar.gz"
14
15 LICENSE="GPL-2"
16 KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86 ~x64-macos"
17 SLOT="0"
18 IUSE="ssl"
19
20 RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6d:= )"
21 DEPEND="${RDEPEND}
22         sys-devel/libtool"
23
24 src_prepare() {
25         # bundled macros break recent libtool
26         sed -i -e 's/AC_PROG_SHELL//' configure.ac || die
27         rm *.m4 || die "failed to remove bundled macros"
28         eautoreconf
29 }
30
31 src_configure() {
32         local myconf
33         use ssl && myconf="--with-ssl=${EPREFIX}/usr" || myconf="--without-ssl"
34         econf ${myconf}
35 }
36
37 src_install() {
38         emake DESTDIR="${D}" install
39
40         dodoc AUTHORS ChangeLog INSTALL README* KNOWNBUGS \
41                 doc/siegerc doc/urls.txt
42
43         newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
44 }
45
46 pkg_postinst() {
47         echo
48         elog "An example ~/.siegerc file has been installed in"
49         elog "${EPREFIX}/usr/share/doc/${PF}/"
50 }