media-gfx/splash-themes-livecd: Merge gentoo-functions use fix
[gentoo.git] / app-benchmarks / pipebench / pipebench-0.40-r1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="3"
6
7 inherit toolchain-funcs
8
9 DESCRIPTION="Measures the speed of stdin/stdout communication"
10 HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=pipebench"
11 SRC_URI="ftp://ftp.habets.pp.se/pub/synscan/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~arm-linux ~x86-linux"
16 IUSE=""
17
18 src_prepare() {
19         sed -i Makefile \
20                 -e 's:CFLAGS=-Wall:CFLAGS+= -Wall:' \
21                 -e 's:$(CFLAGS) -o:$(LDFLAGS) &:g' \
22                 -e "s:/usr/local/bin/:${ED}/usr/bin:" \
23                 -e "s:/usr/local/man/man1/:${ED}/usr/share/man/man1:" \
24                 || die "sed Makefile"
25 }
26
27 src_compile() {
28         emake CC=$(tc-getCC) || die
29 }
30
31 src_install() {
32         dodir /usr/{bin,share/man/man1}
33         emake install || die
34         dodoc README
35 }