Drop $Id$ per council decision in bug #611234.
[gentoo.git] / app-benchmarks / ioping / ioping-1.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eutils
7
8 DESCRIPTION="Simple disk I/0 latency measuring tool"
9 HOMEPAGE="https://github.com/koct9i/ioping"
10 SRC_URI="https://github.com/koct9i/ioping/archive/v1.0.tar.gz -> ${P}.tar.gz"
11
12 SLOT="0"
13 LICENSE="GPL-3"
14 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
15 IUSE=""
16
17 src_prepare() {
18         default
19         sed \
20                 -e 's:LICENSE::g' \
21                 -i Makefile || die
22 }
23
24 src_compile() {
25         emake \
26                 CFLAGS="${CFLAGS}" \
27                 CC="$(tc-getCC)" \
28                 PREFIX="${EPREFIX}/usr"
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
33 }