app-benchmarks/geekbench: amd64 stable wrt bug #659448
[gentoo.git] / app-benchmarks / geekbench / geekbench-4.2.3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
7 HOMEPAGE="https://www.geekbench.com"
8 SRC_URI="https://cdn.geekbench.com/Geekbench-${PV}-Linux.tar.gz"
9
10 KEYWORDS="-* amd64 x86"
11 LICENSE="geekbench"
12 SLOT="4"
13
14 RDEPEND="sys-devel/gcc
15         sys-libs/glibc"
16
17 RESTRICT="bindist fetch mirror strip"
18
19 S="${WORKDIR}/Geekbench-${PV}-Linux"
20
21 QA_PREBUILT="opt/geekbench4/geekbench4 opt/geekbench4/geekbench_x86_32 opt/geekbench4/geekbench_x86_64"
22
23 pkg_nofetch() {
24         elog "Please download ${A} from ${HOMEPAGE}/download/linux"
25         elog "and place it in your DISTDIR directory."
26 }
27
28 src_install() {
29         exeinto "/opt/geekbench4"
30         doexe "geekbench4" "geekbench_x86_32" "geekbench_x86_64"
31
32         insinto "/opt/geekbench4"
33         doins "geekbench.plar"
34
35         dodir "/opt/bin"
36         dosym "../geekbench4/geekbench4" "/opt/bin/geekbench4"
37 }
38
39 pkg_postinst() {
40         elog "If you have purchased a commercial license, you can enter"
41         elog "your email address and your license key with the following command:"
42         elog "geekbench4 -r <email address> <license key>"
43 }