sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / app-benchmarks / bonnie++ / bonnie++-1.97.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 DESCRIPTION="Hard drive bottleneck testing benchmark suite"
7 HOMEPAGE="https://www.coker.com.au/bonnie++/"
8 SRC_URI="https://www.coker.com.au/${PN}/${P}.tgz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~mips ppc ppc64 sparc x86"
13 IUSE="debug"
14
15 S="${WORKDIR}/${P}"
16
17 PATCHES=(
18         "${FILESDIR}/${PN}-1.96-compile-flags.patch" #426788
19         "${FILESDIR}"/${PN}-1.97-zcav-array-indexing-fix.patch #309319
20 )
21
22 DOCS=( README.txt README-2.00 debian/changelog credits.txt )
23 HTML_DOCS=( readme.html )
24
25 src_configure() {
26         econf \
27                 $(usex debug "--enable-debug" "") \
28                 --disable-stripping
29 }
30
31 src_install() {
32         dobin bonnie++ zcav bon_csv2html bon_csv2txt
33         sed -i -e \
34                 "s:/usr/share/doc/bonnie++:${EPREFIX}/usr/share/doc/${PF}/html:g" \
35                 bonnie++.8 || die #431684
36         doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
37         einstalldocs
38 }