app-backup/buttersink: Remove unused dep on flake8
[gentoo.git] / app-backup / tarsnap / tarsnap-1.0.35.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="Online backups for the truly paranoid"
7 HOMEPAGE="http://www.tarsnap.com/"
8 SRC_URI="https://www.tarsnap.com/download/${PN}-autoconf-${PV}.tgz"
9
10 LICENSE="tarsnap"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="acl bzip2 libressl lzma cpu_flags_x86_sse2 xattr"
14
15 RDEPEND="
16         !libressl? ( dev-libs/openssl:0= )
17         libressl? ( dev-libs/libressl:0= )
18         sys-libs/e2fsprogs-libs
19         sys-libs/zlib
20         acl? ( sys-apps/acl )
21         bzip2? ( app-arch/bzip2 )
22         lzma? ( app-arch/xz-utils )
23         xattr? ( sys-apps/attr )"
24 DEPEND="${RDEPEND}
25         virtual/os-headers" # Required for "magic.h"
26
27 S=${WORKDIR}/${PN}-autoconf-${PV}
28
29 src_configure() {
30         econf \
31                 $(use_enable cpu_flags_x86_sse2 sse2) \
32                 $(use_enable xattr) \
33                 $(use_enable acl) \
34                 $(use_with bzip2 bz2lib) \
35                 --without-lzmadec \
36                 $(use_with lzma)
37 }