app-backup/borgmatic: switch to single-implementation mode
[gentoo.git] / app-backup / rsnapshot / rsnapshot-1.4.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils
7
8 DESCRIPTION="A filesystem backup utility based on rsync"
9 HOMEPAGE="http://www.rsnapshot.org"
10 SRC_URI="http://www.rsnapshot.org/downloads/${P}.tar.gz"
11
12 SLOT="0"
13 LICENSE="GPL-2"
14 KEYWORDS="~alpha amd64 ~ppc ~ppc64 ~sparc ~x86"
15
16 RDEPEND=">=dev-lang/perl-5.8.2
17                 dev-perl/Lchown
18                 >=sys-apps/util-linux-2.12-r4
19                 >=sys-apps/coreutils-5.0.91-r4
20                 >=net-misc/openssh-3.7.1_p2-r1
21                 >=net-misc/rsync-2.6.0"
22 DEPEND="${RDEPEND}"
23
24 src_install() {
25         # Change sysconfdir to install the template file as documentation
26         # rather than in /etc.
27         emake install DESTDIR="${D}" \
28                 sysconfdir="${EPREFIX}/usr/share/doc/${PF}"
29
30         dodoc README.md AUTHORS ChangeLog \
31                 docs/Upgrading_from_1.1
32
33         docinto utils
34         dodoc utils/{README,rsnaptar,*.sh,*.pl}
35
36         docinto utils/rsnapshotdb
37         dodoc utils/rsnapshotdb/*
38 }
39
40 pkg_postinst() {
41         elog "The template configuration file has been installed as"
42         elog "/usr/share/doc/${PF}/rsnapshot.conf.default"
43         elog "Copy and edit the the above file as /etc/rsnapshot.conf"
44 }