Merge branch 'master' of git+ssh://git.gentoo.org/repo/gentoo
[gentoo.git] / app-backup / rsnapshot / rsnapshot-1.4.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils
8
9 DESCRIPTION="A filesystem backup utility based on rsync"
10 HOMEPAGE="http://www.rsnapshot.org"
11 SRC_URI="http://www.rsnapshot.org/downloads/${P}.tar.gz"
12
13 SLOT="0"
14 LICENSE="GPL-2"
15 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
16
17 RDEPEND=">=dev-lang/perl-5.8.2
18                 dev-perl/Lchown
19                 >=sys-apps/util-linux-2.12-r4
20                 >=sys-apps/coreutils-5.0.91-r4
21                 >=net-misc/openssh-3.7.1_p2-r1
22                 >=net-misc/rsync-2.6.0"
23 DEPEND="${RDEPEND}"
24
25 src_install() {
26         # Change sysconfdir to install the template file as documentation
27         # rather than in /etc.
28         emake install DESTDIR="${D}" \
29                 sysconfdir="${EPREFIX}/usr/share/doc/${PF}"
30
31         dodoc README.md AUTHORS ChangeLog \
32                 docs/Upgrading_from_1.1
33
34         docinto utils
35         dodoc utils/{README,rsnaptar,*.sh,*.pl}
36
37         docinto utils/rsnapshotdb
38         dodoc utils/rsnapshotdb/*
39 }
40
41 pkg_postinst() {
42         elog "The template configuration file has been installed as"
43         elog "/usr/share/doc/${PF}/rsnapshot.conf.default"
44         elog "Copy and edit the the above file as /etc/rsnapshot.conf"
45 }