app-backup/duplicity: mark python 3.7 compatible
[gentoo.git] / app-backup / reoback / reoback-1.0_p3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils vcs-clean
7
8 DESCRIPTION="Reoback Backup Solution"
9 HOMEPAGE="http://reoback.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/reoback/reoback-${PV/_p/_r}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86"
15 IUSE=""
16
17 RDEPEND=">=dev-lang/perl-5.6.1"
18 DEPEND=">=app-arch/tar-1.13"
19
20 S=${WORKDIR}/${PN}-${PV/_*}
21
22 src_prepare() {
23         ecvs_clean
24         sed \
25                 -e '/^config=/s:=.*:=/etc/reoback/settings.conf:' \
26                 -e '/^reoback=/s:=.*:=/usr/sbin/reoback.pl:' \
27                 -i run_reoback.sh || die
28 }
29
30 src_install() {
31         dosbin reoback.pl
32         insinto /etc/reoback
33         doins conf/*
34         fperms o-x /usr/sbin/reoback.pl
35         insinto /etc/cron.daily
36         newins run_reoback.sh reoback
37         dodoc docs/{BUGS,CHANGES,INSTALL,MANUALS,README,TODO}
38 }
39
40 pkg_postinst() {
41         elog "Reoback can now be activated by simply configuring the files in"
42         elog "/etc/reoback and then doing: chmod +x /etc/cron.daily/reoback"
43 }