x11-plugins/purple-mattermost: drop old
[gentoo.git] / app-backup / rdiff-backup / rdiff-backup-2.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7 inherit distutils-r1
8
9 DESCRIPTION="Local/remote mirroring+incremental backup"
10 HOMEPAGE="https://github.com/rdiff-backup/rdiff-backup"
11 SRC_URI="https://github.com/rdiff-backup/${PN}/releases/download/v${PV}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 arm ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
16 IUSE="examples"
17
18 DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
19         >=net-libs/librsync-1.0:0="
20 RDEPEND="dev-python/pylibacl[${PYTHON_USEDEP}]
21         dev-python/pyxattr[${PYTHON_USEDEP}]
22         >=net-libs/librsync-1.0:0="
23
24 PATCHES=(
25         "${FILESDIR}/${PN}-2.0.0-no-docs.patch"
26 )
27
28 python_install_all() {
29         local DOCS=( docs/FAQ.md )
30         use examples && DOCS+=( docs/examples.md )
31         distutils-r1_python_install_all
32 }