app-backup/rdedup: fix licenses
[gentoo.git] / app-backup / fsarchiver / fsarchiver-0.8.5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 DESCRIPTION="Flexible filesystem archiver for backup and deployment tool"
9 HOMEPAGE="http://www.fsarchiver.org"
10 SRC_URI="https://github.com/fdupoux/${PN}/releases/download/${PV}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="debug lz4 lzma lzo static zstd"
16
17 CDEPEND="dev-libs/libgcrypt:0=
18         >=sys-fs/e2fsprogs-1.41.4
19         lz4? ( app-arch/lz4 )
20         lzma? ( >=app-arch/xz-utils-4.999.9_beta )
21         lzo? ( >=dev-libs/lzo-2.02 )
22         zstd? ( app-arch/zstd )
23 "
24 DEPEND="${CDEPEND}
25         static? (
26                 lz4? ( app-arch/lz4[static-libs] )
27                 lzma? ( app-arch/xz-utils[static-libs] )
28                 lzo? ( dev-libs/lzo[static-libs] )
29                 zstd? ( app-arch/zstd[static-libs] )
30         )"
31 RDEPEND="${DDEPEND}"
32
33 src_prepare() {
34         default
35         sed -i -e 's/^\([a-z]*_CFLAGS.*\)-ggdb/\1/' src/Makefile.am \
36                 || die "seding failed"
37         eautoreconf
38 }
39
40 src_configure() {
41         local myeconfargs=(
42                 $(use_enable debug devel)
43                 $(use_enable lz4)
44                 $(use_enable lzma)
45                 $(use_enable lzo)
46                 $(use_enable static)
47                 $(use_enable zstd)
48         )
49         econf "${myeconfargs[@]}"
50 }