app-backup/dar: Removed old
[gentoo.git] / app-backup / duplicity / duplicity-0.8.12.1612.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_6 python3_7 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Secure backup system using gnupg to encrypt data"
10 HOMEPAGE="http://www.nongnu.org/duplicity/"
11 SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/$(ver_cut 1-3)/+download/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
16 IUSE="s3 test"
17
18 CDEPEND="
19         net-libs/librsync
20         app-crypt/gnupg
21         dev-python/fasteners[${PYTHON_USEDEP}]
22 "
23 DEPEND="${CDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         test? (
26                 app-arch/par2cmdline
27                 dev-python/mock[${PYTHON_USEDEP}]
28                 dev-python/pexpect[${PYTHON_USEDEP}]
29         )
30 "
31 RDEPEND="${CDEPEND}
32         dev-python/paramiko[${PYTHON_USEDEP}]
33         dev-python/future[${PYTHON_USEDEP}]
34         s3? ( dev-python/boto[${PYTHON_USEDEP}] )
35 "
36
37 RESTRICT="test"
38
39 PATCHES=(
40         "${FILESDIR}/${P}-fix-docs.patch"
41 )
42
43 python_test() {
44         esetup.py test
45 }
46
47 pkg_postinst() {
48         elog "Duplicity has many optional dependencies to support various backends."
49         elog "Currently it's up to you to install them as necessary."
50 }