app-backup/rdiff-backup: 2.0.0 bump
[gentoo.git] / app-backup / duplicity / duplicity-0.7.12.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1 versionator
8
9 DESCRIPTION="Secure backup system using gnupg to encrypt data"
10 HOMEPAGE="http://www.nongnu.org/duplicity/"
11 SRC_URI="https://code.launchpad.net/${PN}/$(get_version_component_range 1-2)-series/${PV}/+download/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
16 IUSE="s3 test"
17
18 CDEPEND="
19         net-libs/librsync
20         app-crypt/gnupg
21         dev-python/lockfile
22 "
23 DEPEND="${CDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         test? (
26                 dev-python/mock[${PYTHON_USEDEP}]
27                 dev-python/pexpect[${PYTHON_USEDEP}]
28         )
29 "
30 RDEPEND="${CDEPEND}
31         dev-python/paramiko[${PYTHON_USEDEP}]
32         s3? ( dev-python/boto[${PYTHON_USEDEP}] )
33 "
34
35 RESTRICT="!test? ( test )"
36
37 python_prepare_all() {
38         # workaround until failing test is fixed
39         local PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
40
41         distutils-r1_python_prepare_all
42
43         sed -i "s/'COPYING',//" setup.py || die
44 }
45
46 python_test() {
47         esetup.py test
48 }
49
50 pkg_postinst() {
51         elog "Duplicity has many optional dependencies to support various backends."
52         elog "Currently it's up to you to install them as necessary."
53 }