app-backup/cdbackup: Whitespace cleanup
[gentoo.git] / app-backup / cdbackup / cdbackup-0.7.1-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Allows streaming backup utilities to dump/restore from CD-R(W)s or DVD(+/-RW)s"
9 HOMEPAGE="http://www.muempf.de/index.html"
10 SRC_URI="http://www.muempf.de/down/${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND=">=app-cdr/cdrtools-1.11.28"
18 DEPEND=""
19
20 src_prepare() {
21         sed -i -e '/cd\(backup\|restore\)/,+1 s:CFLAGS:LDFLAGS:' \
22                 "${S}"/Makefile || die "sed Makefile failed"
23         default
24 }
25
26 src_compile() {
27         emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
28 }
29
30 src_install() {
31         dobin cdbackup cdrestore
32         doman cdbackup.1 cdrestore.1
33         dodoc CHANGES CREDITS README
34 }