app-backup/duplicity: amd64 stable
[gentoo.git] / app-backup / btrbk / btrbk-0.26.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit systemd
7
8 if [[ ${PV} == "9999" ]] ; then
9         EGIT_REPO_URI="git://dev.tty0.ch/btrbk.git"
10         inherit git-r3
11         SRC_URI=""
12 else
13         SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
14         KEYWORDS="~amd64 ~arm ~x86"
15 fi
16
17 DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
18 HOMEPAGE="https://digint.ch/btrbk/"
19 LICENSE="GPL-3+"
20 SLOT="0"
21 IUSE="+pv"
22
23 DEPEND=">=app-text/asciidoc-8.6.0
24         app-text/xmlto"
25
26 RDEPEND="dev-lang/perl
27         net-misc/openssh
28         pv? ( sys-apps/pv )
29         >=sys-fs/btrfs-progs-3.18.2"
30
31 src_install() {
32         emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" install
33 }
34 pkg_preinst() {
35         if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
36                 upgrade_0_26_0_warning="1"
37         fi
38 }
39 pkg_postinst() {
40         if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
41                 ewarn "If you are using raw targets, make sure to run the"
42                 ewarn "\"raw_suffix2sidecar\" utility in each target directory."
43         fi
44 }