Merge branch 'marbre-notebook'
[gentoo.git] / app-backup / borgbackup / borgbackup-9999.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 PYTHON_COMPAT=( python3_4 )
8
9 inherit distutils-r1
10
11 if [[ ${PV} == "9999" ]] ; then
12         EGIT_REPO_URI="https://github.com/${PN}/borg.git"
13         inherit git-r3
14 else
15         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
16         KEYWORDS="~amd64 ~x86"
17 fi
18
19 DESCRIPTION="Deduplicating backup program with compression and authenticated encryption."
20 HOMEPAGE="https://borgbackup.readthedocs.io/"
21
22 LICENSE="BSD"
23 SLOT="0"
24 IUSE="libressl +fuse"
25
26 # Unformately we have a file conflict with app-office/borg, bug #580402
27 RDEPEND="
28         !!app-office/borg
29         app-arch/lz4
30         dev-python/msgpack[${PYTHON_USEDEP}]
31         !libressl? ( dev-libs/openssl:0= )
32         libressl? ( dev-libs/libressl:0= )
33         fuse? ( dev-python/llfuse[${PYTHON_USEDEP}] )
34 "
35
36 DEPEND="
37         dev-python/setuptools_scm[${PYTHON_USEDEP}]
38         dev-python/cython[${PYTHON_USEDEP}]
39         ${RDEPEND}
40 "