media-libs/gst-rtsp-server: bump to 1.12.2
[gentoo.git] / app-backup / attic / attic-0.16.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 PYTHON_COMPAT=( python3_{4,5} )
7
8 inherit distutils-r1
9
10 if [[ ${PV} == "9999" ]] ; then
11         EGIT_REPO_URI="https://github.com/jborg/attic.git"
12         inherit git-r3
13 else
14         SRC_URI="https://github.com/jborg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
15         KEYWORDS="~amd64 ~x86"
16 fi
17
18 DESCRIPTION="Attic is a deduplicating backup program written in Python."
19 HOMEPAGE="https://attic-backup.org/"
20
21 LICENSE="BSD"
22 SLOT="0"
23 IUSE="libressl"
24
25 RDEPEND="
26         dev-python/msgpack[${PYTHON_USEDEP}]
27         !libressl? ( dev-libs/openssl:0= )
28         libressl? ( dev-libs/libressl:0= )
29         dev-python/llfuse[${PYTHON_USEDEP}]"
30
31 DEPEND="
32         dev-python/setuptools[${PYTHON_USEDEP}]
33         dev-python/cython[${PYTHON_USEDEP}]
34         ${RDEPEND}"