*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-arch / vimball / vimball-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python{3_6,3_7} )
6 inherit distutils-r1
7
8 if [[ ${PV} == *9999 ]] ; then
9         EGIT_REPO_URI="https://github.com/radhermit/vimball.git"
10         inherit git-r3
11 else
12         KEYWORDS="~amd64 ~x86"
13         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14 fi
15
16 DESCRIPTION="a command-line vimball archive extractor"
17 HOMEPAGE="https://github.com/radhermit/vimball"
18
19 LICENSE="MIT"
20 SLOT="0"
21 IUSE="test"
22 RESTRICT="!test? ( test )"
23
24 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
25 RDEPEND="${BDEPEND}"
26 DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
27
28 python_test() {
29         esetup.py test
30 }