app-arch/unarj: Use mirror://gentoo
[gentoo.git] / app-arch / unarj / unarj-2.65.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Utility for opening arj archives"
9 HOMEPAGE="http://www.arjsoftware.com/"
10 SRC_URI="mirror://gentoo/${P}.tgz"
11
12 LICENSE="arj"
13 SLOT="0"
14 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
15 IUSE=""
16
17 PATCHES=(
18         "${FILESDIR}"/${P}-CAN-2004-0947.patch
19         "${FILESDIR}"/${P}-sanitation.patch
20         "${FILESDIR}"/${P}-gentoo-fbsd.patch
21         "${FILESDIR}"/${PN}-2.65-Wformat-security.patch
22 )
23
24 src_configure() {
25         tc-export CC
26 }
27
28 src_install() {
29         dobin unarj
30         dodoc unarj.txt technote.txt
31 }