app-arch/par2cmdline: version bump to 0.7.0
[gentoo.git] / app-arch / par2cmdline / par2cmdline-0.7.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="A PAR-2.0 file verification and repair tool"
9 HOMEPAGE="https://github.com/Parchive/par2cmdline"
10 SRC_URI="https://github.com/Parchive/${PN}/releases/download/v${PV}/${P}.tar.xz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
15 IUSE="openmp"
16
17 DOCS="AUTHORS ChangeLog README" # NEWS is empty, PORTING and ROADMAP are for building
18
19 pkg_pretend() {
20         [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
21 }
22
23 pkg_setup() {
24         [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
25 }
26
27 src_test() {
28         # test22 fails when run in parallel
29         emake -j1 check
30 }