app-arch/lzip: stable 1.21 for ia64, bug #679898
[gentoo.git] / app-arch / lzip / lzip-1.21.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="lossless data compressor based on the LZMA algorithm"
9 HOMEPAGE="https://www.nongnu.org/lzip/lzip.html"
10 SRC_URI="https://download.savannah.gnu.org/releases-noredirect/${PN}/${P/_/-}.tar.gz
11         https://download.savannah.gnu.org/releases/${PN}/${P/_/-}.tar.gz"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16
17 S="${WORKDIR}/${P/_/-}"
18
19 src_configure() {
20         # not autotools-based
21         ./configure \
22                 --prefix="${EPREFIX}"/usr \
23                 CXX="$(tc-getCXX)" \
24                 CPPFLAGS="${CPPFLAGS}" \
25                 CXXFLAGS="${CXXFLAGS}" \
26                 LDFLAGS="${LDFLAGS}" || die
27 }