app-arch/dpkg: Version 1.19.7
[gentoo.git] / app-arch / hardlink / hardlink-0.3.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit toolchain-funcs
6
7 DESCRIPTION="A tool which replaces copies of a file with hardlinks"
8 HOMEPAGE="https://jak-linux.org/projects/hardlink/"
9 #SRC_URI="https://jak-linux.org/projects/${PN}/${PN}_${PV}.tar.xz"
10 SRC_URI="https://salsa.debian.org/jak/${PN}/-/archive/${PV}/${P}.tar.bz2"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
15
16 RDEPEND="dev-libs/libpcre"
17 DEPEND="${RDEPEND}"
18 BDEPEND="virtual/pkgconfig"
19
20 DOCS=( README ${T}/README.rsync )
21
22 src_prepare() {
23         default
24         sed -i -e '/^CF/s:?=:+=:' -e '/^CF/s:-O2 -g::' Makefile || die
25
26         cat <<-EOF > "${T}"/README.rsync
27         https://hardlinkpy.googlecode.com/svn/trunk/hardlink.py has regex '^\..*\.\?{6,6}$'
28         for excluding rsync temporary files by default.
29
30         To accomplish same with this version, you can use following syntax:
31         # hardlink -x '^\..*\.\?{6,6}$'
32
33         This was discussed at https://bugs.gentoo.org/416613
34         EOF
35 }
36
37 src_compile() {
38         emake CC=$(tc-getCC)
39 }