app-arch/rpm2targz: drop old
[gentoo.git] / app-arch / dpkg / dpkg-1.19.0.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils multilib autotools ltprune toolchain-funcs
6
7 DESCRIPTION="Package maintenance system for Debian"
8 HOMEPAGE="https://packages.qa.debian.org/dpkg"
9 SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
10
11 LICENSE="GPL-2+"
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
14 IUSE="+bzip2 +lzma nls selinux test unicode +update-alternatives +zlib"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         >=dev-lang/perl-5.14.2:=
19         bzip2? ( app-arch/bzip2 )
20         lzma? ( app-arch/xz-utils )
21         selinux? ( sys-libs/libselinux )
22         zlib? ( >=sys-libs/zlib-1.1.4 )
23 "
24 DEPEND="
25         ${RDEPEND}
26         app-arch/xz-utils
27         sys-devel/flex
28         virtual/pkgconfig
29         nls? (
30                 app-text/po4a
31                 >=sys-devel/gettext-0.18.2
32         )
33         test? (
34                 dev-perl/IO-String
35                 dev-perl/Test-Pod
36                 virtual/perl-Test-Harness
37         )
38 "
39
40 DOCS=(
41         ChangeLog
42         THANKS
43         TODO
44 )
45 PATCHES=(
46         "${FILESDIR}"/${PN}-1.18.12-dpkg_buildpackage-test.patch
47         "${FILESDIR}"/${PN}-1.18.12-flags.patch
48         "${FILESDIR}"/${PN}-1.18.12-rsyncable.patch
49 )
50
51 src_prepare() {
52         use nls && strip-linguas -i po
53
54         default
55
56         eautoreconf
57 }
58
59 src_configure() {
60         tc-export CC
61         econf \
62                 $(use_enable nls) \
63                 $(use_enable unicode) \
64                 $(use_enable update-alternatives) \
65                 $(use_with bzip2 libbz2) \
66                 $(use_with lzma liblzma) \
67                 $(use_with selinux libselinux) \
68                 $(use_with zlib libz) \
69                 --disable-compiler-warnings \
70                 --disable-dselect \
71                 --disable-start-stop-daemon \
72                 --localstatedir="${EPREFIX}"/var \
73                 --without-libmd
74 }
75
76 src_compile() {
77         emake AR=$(tc-getAR)
78 }
79
80 src_install() {
81         default
82
83         keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
84         keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
85
86         prune_libtool_files
87 }