4f5966691a58404e9fc509f645c1728d2c8bfd6c
[gentoo.git] / app-arch / cpio / cpio-2.13.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="A file archival tool which can also read and write tar files"
7 HOMEPAGE="https://www.gnu.org/software/cpio/cpio.html"
8 SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
9
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
13 IUSE="nls"
14
15 PATCHES=(
16         "${FILESDIR}"/${PN}-2.12-non-gnu-compilers.patch #275295
17         "${FILESDIR}"/${PN}-2.12-gcc-10.patch #705900
18 )
19
20 src_configure() {
21         local myeconfargs=(
22                 $(use_enable nls)
23                 --bindir="${EPREFIX}"/bin
24                 --with-rmt="${EPREFIX}"/usr/sbin/rmt
25         )
26         econf "${myeconfargs[@]}"
27 }