Merge remote-tracking branch 'github/pr/851'.
[gentoo.git] / app-arch / cpio / cpio-2.12.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit eutils
8
9 DESCRIPTION="A file archival tool which can also read and write tar files"
10 HOMEPAGE="https://www.gnu.org/software/cpio/cpio.html"
11 SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16 IUSE="nls"
17
18 src_prepare() {
19         epatch "${FILESDIR}"/${PN}-2.12-non-gnu-compilers.patch #275295
20 }
21
22 src_configure() {
23         econf \
24                 $(use_enable nls) \
25                 --bindir="${EPREFIX}"/bin \
26                 --with-rmt="${EPREFIX}"/usr/sbin/rmt
27 }