dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / app-arch / cabextract / cabextract-1.8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Extracts files from Microsoft cabinet archive files"
9 HOMEPAGE="https://www.cabextract.org.uk/"
10 SRC_URI="https://www.cabextract.org.uk/${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
15 IUSE="extras"
16
17 RDEPEND="extras? ( dev-lang/perl )"
18
19 src_prepare() {
20         default
21         # the code attempts to set up a fnmatch replacement, but then fails to code
22         # it properly leading to undefined references to rpl_fnmatch().  This may be
23         # removed in the future if building still works by setting "yes" to "no".
24         export ac_cv_func_fnmatch_works=yes
25 }
26
27 src_compile() {
28         emake AR="$(tc-getAR)"
29 }
30
31 src_install() {
32         local DOCS=( AUTHORS ChangeLog INSTALL NEWS README TODO doc/magic )
33         default
34         docinto html
35         dodoc doc/wince_cab_format.html
36         if use extras; then
37                 dobin src/{wince_info,wince_rename,cabinfo,cabsplit}
38         fi
39 }