media-libs/portaudio: Version bump
[gentoo.git] / app-admin / yadm / yadm-1.06.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 DESCRIPTION="A dotfile manager for the config files in your home folder"
8 HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
9 SRC_URI="https://github.com/TheLocehiliosan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="test"
15
16 DOCS=( CHANGES CONTRIBUTORS README.md )
17
18 DEPEND="
19         test? (
20                 dev-util/bats
21                 dev-vcs/git
22         )"
23 RDEPEND="dev-vcs/git
24         app-crypt/gnupg"
25
26 src_compile() {
27         emake yadm.md
28 }
29
30 src_test() {
31         # 109_accept_encryption tests are interactive, thus fail. Skip them
32         bats $(find test/ -type f -name '*.bats' -and -not -name '109_accept_encryption.bats') \
33                 || die "Tests failed"
34 }
35
36 src_install() {
37         einstalldocs
38
39         dobin "${PN}"
40         doman "${PN}.1"
41 }