dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / app-admin / recursos / recursos-2.0-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 DESCRIPTION="Script to create html and text report about your system"
7 HOMEPAGE="http://www.josealberto.org"
8 SRC_URI="mirror://gentoo/${P}.tbz2"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14
15 DEPEND=""
16 RDEPEND="app-shells/bash
17         net-analyzer/rrdtool[graph]
18         virtual/imagemagick-tools"
19
20 S=${WORKDIR}/r2
21
22 src_install() {
23         WWWDIR="/var/www/localhost/htdocs/R2"
24
25         insinto /etc
26         doins recursos2.conf
27
28         dobin R2createrrd.sh R2generarrd.sh R2updaterrd.sh Recursos2.sh
29
30         dodir ${WWWDIR}
31         insinto ${WWWDIR}
32         doins R2/*.html
33
34         dodir ${WWWDIR}/common
35         insinto ${WWWDIR}/common
36         doins R2/common/*
37
38         dodir ${WWWDIR}/rrd/mini
39 }
40
41 pkg_postinst() {
42         elog "Fist you must configure /etc/recursos2.conf"
43         elog "Then follow these steps:"
44         elog
45         elog "1. Run R2createrrd.sh"
46         elog
47         elog "2. Add crontab jobs (this is an example):"
48         elog "*/2 * * * *     root    /usr/bin/R2updaterrd.sh"
49         elog "*/5 * * * *     root    /usr/bin/R2generarrd.sh"
50         elog "*/10 * * * *    root    /usr/bin/Recursos2.sh \ "
51         elog "    title general system disks net \ "
52         elog "    > /var/www/localhost/htdocs/recursos.html"
53         elog
54         elog "You can use Recursos2.sh to extract info about your system"
55         elog "in html or plain text and mail the file or whatever."
56         elog
57 }