Use https by default
[gentoo.git] / app-admin / python-updater / python-updater-0.13.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 if [[ "${PV}" == "9999" ]]; then
8         inherit git-r3
9 fi
10
11 DESCRIPTION="Script used to reinstall Python packages after changing of active Python versions"
12 HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
13 if [[ "${PV}" == "9999" ]]; then
14         EGIT_REPO_URI="git://anongit.gentoo.org/proj/python-updater.git"
15 else
16         SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
17         KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
18 fi
19
20 LICENSE="GPL-2"
21 SLOT="0"
22 IUSE=""
23
24 if [[ ${PV} == 9999 ]]; then
25         DEPEND="
26                 sys-apps/gentoo-functions
27                 sys-apps/help2man
28         "
29 fi
30 RDEPEND="
31         sys-apps/gentoo-functions
32         || ( >=sys-apps/portage-2.1.6 >=sys-apps/paludis-0.56.0 sys-apps/pkgcore )
33 "
34
35 src_compile() {
36         [[ ${PV} == 9999 ]] && emake python-updater
37         default
38 }