Use https by default
[gentoo.git] / app-admin / python-updater / python-updater-0.11.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 if [[ "${PV}" == "9999" ]]; then
8         inherit git-2
9 fi
10
11 DESCRIPTION="Script used to reinstall Python packages after changing of active Python versions"
12 HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
13 if [[ "${PV}" == "9999" ]]; then
14         SRC_URI=""
15         EGIT_REPO_URI="git://anongit.gentoo.org/proj/python-updater.git"
16 else
17         SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
18         KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
19 fi
20
21 LICENSE="GPL-2"
22 SLOT="0"
23 IUSE=""
24
25 DEPEND="$([[ "${PV}" == "9999" ]] && echo "sys-apps/help2man")"
26 RDEPEND="|| ( >=sys-apps/portage-2.1.6 >=sys-apps/paludis-0.56.0 )"
27
28 src_compile() {
29         if [[ "${PV}" == "9999" ]]; then
30                 emake ${PN}.1 || die "Generation of man page failed"
31         fi
32 }
33
34 src_install() {
35         dosbin ${PN}
36         doman ${PN}.1
37         dodoc AUTHORS
38 }