94887b362240cae53df5d645e4953bd269966894
[gentoo.git] / app-admin / pydf / pydf-12.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_7,3_4} )
7 inherit python-r1
8
9 DESCRIPTION="Enhanced df with colors"
10 HOMEPAGE="http://kassiopeia.juls.savba.sk/~garabik/software/pydf/"
11 SRC_URI="http://kassiopeia.juls.savba.sk/~garabik/software/pydf/${PN}_${PV}.tar.gz"
12
13 LICENSE="public-domain"
14 SLOT="0"
15 KEYWORDS="amd64 arm ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
16 IUSE=""
17
18 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
19 DEPEND="${PYTHON_DEPS}"
20 RDEPEND="${DEPEND}"
21
22 src_prepare() {
23         sed -i -e "s:/etc/pydfrc:${EPREFIX}/etc/pydfrc:" pydf || die
24 }
25
26 src_install() {
27         python_foreach_impl python_doscript pydf
28         insinto /etc
29         doins pydfrc
30         doman pydf.1
31         dodoc README
32 }