app-admin/pydf: take over maintainership.
[gentoo.git] / app-admin / pydf / pydf-12-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_4,3_5} )
6
7 inherit python-r1
8
9 DESCRIPTION="Enhanced df with colors"
10 HOMEPAGE="http://kassiopeia.juls.savba.sk/~garabik/software/pydf/"
11 SRC_URI="http://kassiopeia.juls.savba.sk/~garabik/software/pydf/${PN}_${PV}.tar.gz"
12
13 LICENSE="public-domain"
14 SLOT="0"
15 KEYWORDS="amd64 arm ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
16
17 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
18 DEPEND="${PYTHON_DEPS}"
19 RDEPEND="${DEPEND}"
20
21 DOCS=( README )
22
23 src_prepare() {
24         default
25         sed -i -e "s:/etc/pydfrc:${EPREFIX}/etc/pydfrc:" "${PN}" || die
26 }
27
28 src_install() {
29         python_foreach_impl python_doscript "${PN}"
30         insinto /etc
31         doins "${PN}rc"
32         doman "${PN}.1"
33         einstalldocs
34 }