f83697e20877c9698c17ce04b0e97957a9d2c598
[gentoo.git] / app-admin / pwman3 / pwman3-0.9.11.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_5 python3_6 )
7 PYTHON_REQ_USE="sqlite?"
8 inherit distutils-r1
9
10 DESCRIPTION="A lightweight password-manager with multiple database backends"
11 HOMEPAGE="https://pwman3.github.io/pwman3/"
12 SRC_URI="https://github.com/pwman3/pwman3/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="mongodb mysql postgres +sqlite test"
18 RESTRICT="!test? ( test )"
19
20 COMMON="
21         >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
22         >=dev-python/colorama-0.3.0[${PYTHON_USEDEP}]
23         "
24
25 DEPEND="
26         ${COMMON}
27         test? ( dev-python/pexpect[${PYTHON_USEDEP}] )
28         "
29
30 RDEPEND="
31         ${COMMON}
32         mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
33         mysql? ( dev-python/pymysql[${PYTHON_USEDEP}] )
34         postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )
35         "
36
37 python_test() {
38         esetup.py test
39 }