net-misc/openssh: arm64 stable (bug #710924)
[gentoo.git] / app-admin / pass-otp / pass-otp-1.2.0.ebuild
1 # Copyright 2018-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit bash-completion-r1
7
8 DESCRIPTION="A pass extension for managing one-time-password (OTP) tokens."
9 HOMEPAGE="https://github.com/tadfisher/pass-otp"
10 SRC_URI="https://github.com/tadfisher/pass-otp/releases/download/v${PV}/${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc64 x86"
15 IUSE="qrcode test"
16 RESTRICT="!test? ( test )"
17
18 DEPEND="test? ( dev-tcltk/expect:* )"
19
20 RDEPEND=">=app-admin/pass-1.7
21         sys-auth/oath-toolkit
22         qrcode? ( media-gfx/qrencode )"
23
24 src_compile() {
25         :
26 }
27
28 src_install() {
29         emake install DESTDIR="${D}" BASHCOMPDIR="$(get_bashcompdir)"
30 }