app-admin/systemrescuecd-x86: Bump to 5.3.0
[gentoo.git] / app-admin / needrestart / needrestart-3.3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 if [[ ${PV} == "9999" ]] ; then
7         EGIT_REPO_URI="https://github.com/liske/${PN}.git"
8         inherit git-r3
9         SRC_URI=""
10         KEYWORDS="amd64 x86"
11 else
12         SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13         KEYWORDS="amd64 x86"
14 fi
15
16 DESCRIPTION="Restart daemons after library updates"
17 HOMEPAGE="https://fiasko-nw.net/~thomas/tag/needrestart.html https://github.com/liske/needrestart"
18
19 SLOT="0"
20 LICENSE="GPL-2+"
21
22 RDEPEND="
23         >=sys-apps/sed-4.2.2
24         dev-lang/perl:=
25         dev-perl/libintl-perl
26         dev-perl/Module-Find
27         dev-perl/Module-ScanDeps
28         dev-perl/Proc-ProcessTable
29         dev-perl/Sort-Naturally
30         dev-perl/TermReadKey
31         sys-apps/init-system-helpers
32 "
33 DEPEND="${RDEPEND}
34         sys-devel/gettext
35 "
36
37 src_install() {
38         default
39         doman man/*.1
40         dodoc -r ex
41 }