app-admin/logcheck: Drop old
[gentoo.git] / app-admin / ksonnet / ksonnet-0.8.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 EGO_PN="github.com/ksonnet/ksonnet"
7
8 inherit golang-build golang-vcs-snapshot bash-completion-r1
9
10 ARCHIVE_URI="https://github.com/ksonnet/ksonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11 KEYWORDS="~amd64"
12
13 DESCRIPTION="CLI-supported framework for extensible Kubernetes configurations"
14 HOMEPAGE="https://github.com/ksonnet/ksonnet http://ksonnet.heptio.com/"
15 SRC_URI="${ARCHIVE_URI}"
16
17 LICENSE="Apache-2.0"
18 SLOT="0"
19 IUSE=""
20
21 RESTRICT="test"
22
23 src_prepare() {
24         default
25         sed -i -e "s/EXTRA_GO_FLAGS =/EXTRA_GO_FLAGS = -v /"\
26                 -e "s/VERSION =.*/VERSION = ${PV}/" src/${EGO_PN}/Makefile || die
27 }
28
29 src_compile() {
30         pushd src/${EGO_PN} || die
31         GOPATH="${S}" emake ks
32         popd || die
33 }
34
35 src_install() {
36         pushd src/${EGO_PN} || die
37         dobin ks
38         dodoc README.md
39         popd || die
40 }