dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-admin / doas / doas-6.6.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Run commands as super user or another user, alternative to sudo from OpenBSD"
9
10 MY_PN=OpenDoas
11 MY_P=${MY_PN}-${PV}
12 HOMEPAGE="https://github.com/Duncaen/OpenDoas"
13 SRC_URI="https://github.com/Duncaen/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
14 S="${WORKDIR}"/${MY_P}
15
16 LICENSE="ISC"
17 SLOT="0"
18 KEYWORDS="~amd64 ~arm"
19 IUSE="pam"
20
21 RDEPEND="pam? ( sys-libs/pam )"
22 DEPEND="${RDEPEND}
23         virtual/yacc"
24
25 src_prepare() {
26         default
27         sed -i 's/-Werror //' Makefile || die
28 }
29
30 src_configure() {
31         tc-export CC AR
32         ./configure \
33                 --prefix="${EPREFIX}"/usr \
34                 --sysconfdir="${EPREFIX}"/etc \
35                 $(use_with pam) \
36                 || die
37 }