Merge media-sound/spotify: Fix homepage URL
[gentoo.git] / app-admin / conkyforecast / conkyforecast-2.24-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # upstream broke setup.py to install into /usr/share...
8 DISTUTILS_SINGLE_IMPL=1
9 PYTHON_COMPAT=( python2_7 )
10
11 inherit distutils-r1
12
13 DESCRIPTION="Conky weather forecast script with support for language files"
14 HOMEPAGE="https://launchpad.net/~conky-companions"
15 SRC_URI="https://launchpad.net/~conky-companions/+archive/ppa/+files/${PN}_${PV}.tar.gz"
16
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE=""
21
22 RDEPEND="app-admin/conky"
23
24 S=${WORKDIR}/src
25
26 python_prepare_all() {
27         sed -i -e "s:pythoncmd=.*$:pythoncmd=${EPYTHON}:" conkyForecast* || die
28
29         distutils-r1_python_prepare_all
30 }
31
32 python_install() {
33         distutils-r1_python_install
34
35         python_optimize "${ED%/}"/usr/share/${PN}
36 }
37
38 pkg_postinst() {
39         elog "You have to define a partner id and registration code for "
40         elog "the weather.com xoap. You need to copy the template from"
41         elog "/usr/share/conkyforecast/conkyForecast.config into you account"
42         elog "as ~/.conkyForecast.config and edit the respective fields."
43         elog
44         elog "More details can be found in the README file."
45 }