app-admin/cdist: bump to 6.0.0
[gentoo.git] / app-admin / cdist / cdist-6.0.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{3_5,3_6,3_7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A usable configuration management system"
11 HOMEPAGE="https://www.nico.schottelius.org/software/cdist/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="doc"
18
19 python_install_all() {
20         use doc && local HTML_DOCS=( docs/dist/html/*.html docs/dist/html/man{1,7}/*.html )
21         distutils-r1_python_install_all
22
23         doman docs/dist/man/man1/*.1 docs/dist/man/man7/*.7
24 }