dev-qt/qtsql: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-admin / ccze / ccze-0.2.1-r4.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit fixheadtails autotools eutils toolchain-funcs
7
8 DESCRIPTION="A flexible and fast logfile colorizer"
9 HOMEPAGE="https://github.com/madhouse/ccze/releases"
10 SRC_URI="mirror://gentoo/${P}.tar.gz"
11
12 RESTRICT="test"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm ppc x86"
17 IUSE=""
18
19 DEPEND="dev-libs/libpcre
20         sys-libs/ncurses:0="
21
22 RDEPEND="${DEPEND}"
23
24 DOCS=( AUTHORS ChangeLog ChangeLog-0.1 NEWS THANKS README FAQ )
25
26 PATCHES=(
27         "${FILESDIR}"/ccze-fbsd.patch
28         "${FILESDIR}"/ccze-segfault.patch
29         "${FILESDIR}"/ccze-ldflags.patch
30         "${FILESDIR}"/${P}-tinfo.patch
31 )
32
33 src_prepare() {
34         default
35
36         # GCC 4.x fixes
37         sed -e 's/-Wswitch -Wmulticharacter/-Wswitch/' \
38             -i src/Makefile.in || die
39         sed -e '/AC_CHECK_TYPE(error_t, int)/d' \
40             -i configure.ac || die
41
42         eautoreconf
43
44         ht_fix_file Rules.mk.in
45
46         tc-export CC
47 }