Use https by default
[gentoo.git] / app-admin / ccze / ccze-0.2.1-r3.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit fixheadtails autotools eutils toolchain-funcs
8
9 DESCRIPTION="A flexible and fast logfile colorizer"
10 HOMEPAGE="https://dev.gentoo.org/~joker/ccze/ccze.txt"
11 SRC_URI="mirror://gentoo/${P}.tar.gz"
12
13 RESTRICT="test"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="amd64 ppc x86 ~x86-fbsd"
18 IUSE=""
19
20 DEPEND="dev-libs/libpcre
21         sys-libs/ncurses"
22
23 RDEPEND="${DEPEND}"
24
25 DOCS=( AUTHORS ChangeLog ChangeLog-0.1 NEWS THANKS README FAQ )
26
27 src_prepare() {
28
29         epatch "${FILESDIR}"/ccze-fbsd.patch
30         epatch "${FILESDIR}"/ccze-segfault.patch
31         epatch "${FILESDIR}"/ccze-ldflags.patch
32         epatch "${FILESDIR}"/${P}-tinfo.patch
33
34         # GCC 4.x fixes
35         sed -e 's/-Wswitch -Wmulticharacter/-Wswitch/' \
36             -i src/Makefile.in || die
37         sed -e '/AC_CHECK_TYPE(error_t, int)/d' \
38             -i configure.ac || die
39
40         eautoreconf
41
42         ht_fix_file Rules.mk.in
43
44         tc-export CC
45 }