app-admin/augeas: fix MissingTestRestrict
[gentoo.git] / app-admin / augeas / augeas-1.11.0-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="A library for changing configuration files"
9 HOMEPAGE="http://augeas.net/"
10 SRC_URI="http://download.augeas.net/${P}.tar.gz"
11
12 SLOT="0"
13 LICENSE="LGPL-2.1"
14 KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ppc ~ppc64 sparc x86"
15 IUSE="static-libs test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         dev-libs/libxml2
20         sys-libs/readline:="
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig
23         >=app-doc/NaturalDocs-1.40
24         test? ( dev-lang/ruby )"
25
26 PATCHES=(
27 )
28
29 src_prepare() {
30         default
31         eautoreconf
32 }
33
34 src_configure() {
35         # selinux needs to implemented
36         econf \
37                 --without-selinux \
38                 $(use_enable static-libs static)
39 }
40
41 src_compile() {
42         addpredict /usr/share/NaturalDocs/Config/Languages.txt
43         addpredict /usr/share/NaturalDocs/Config/Topics.txt
44         default
45 }
46
47 src_install() {
48         default
49         use static-libs || find "${D}" -name '*.la' -delete || die
50 }