dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / app-admin / ansible-lint / ansible-lint-4.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DISTUTILS_USE_SETUPTOOLS=rdepend
7 PYTHON_COMPAT=( python3_{6,7} )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
12 HOMEPAGE="https://github.com/ansible/ansible-lint"
13 SRC_URI="https://github.com/ansible/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20 PATCHES="${FILESDIR}/${P}-specifierset-split-setuptools.patch"
21
22 CDEPEND="app-admin/ansible[${PYTHON_USEDEP}]
23                 dev-python/pyyaml[${PYTHON_USEDEP}]
24                 dev-python/six[${PYTHON_USEDEP}]"
25 DEPEND="dev-python/ruamel-yaml[${PYTHON_USEDEP}]
26                 dev-python/setuptools[${PYTHON_USEDEP}]
27                 dev-python/setuptools_scm[${PYTHON_USEDEP}]
28                 dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
29                 test? (
30                         dev-python/flake8[${PYTHON_USEDEP}]
31                         dev-python/nose[${PYTHON_USEDEP}]
32                         dev-python/wheel[${PYTHON_USEDEP}]
33                 )
34                 ${CDEPEND}"
35 RDEPEND="${CDEPEND}"
36
37 python_test() {
38         nosetests || die
39 }