dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / app-admin / ansible-lint / ansible-lint-4.0.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
11 HOMEPAGE="https://github.com/ansible/ansible-lint"
12 SRC_URI="https://github.com/ansible/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 CDEPEND="app-admin/ansible[${PYTHON_USEDEP}]
21                 dev-python/pyyaml[${PYTHON_USEDEP}]
22                 dev-python/six[${PYTHON_USEDEP}]"
23 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
24                 dev-python/setuptools-git[${PYTHON_USEDEP}]
25                 dev-python/setuptools_scm[${PYTHON_USEDEP}]
26                 dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
27                 test? (
28                         dev-python/flake8[${PYTHON_USEDEP}]
29                         dev-python/nose[${PYTHON_USEDEP}]
30                         dev-python/wheel[${PYTHON_USEDEP}]
31                 )
32                 ${CDEPEND}"
33 RDEPEND="${CDEPEND}"
34
35 python_test() {
36         nosetests || die
37 }