sci-mathematics/rstudio: Thanks to tomboy-64 for fixing bug Bug 534152 - sci-mathemat...
[gentoo.git] / app-admin / ansible / ansible-9999.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit distutils-r1 eutils git-r3
10
11 DESCRIPTION="Model-driven deployment, config management, and command execution framework"
12 HOMEPAGE="http://ansible.com/"
13 # the version here is special because upstream did a 2.0.0 release on accident one time...
14 EGIT_REPO_URI="git://github.com/ansible/ansible.git"
15 EGIT_BRANCH="devel"
16
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS=""
20 IUSE="keyczar test"
21
22 RDEPEND="
23         keyczar? ( dev-python/keyczar[${PYTHON_USEDEP}] )
24         dev-python/paramiko[${PYTHON_USEDEP}]
25         dev-python/jinja[${PYTHON_USEDEP}]
26         dev-python/pyyaml[${PYTHON_USEDEP}]
27         dev-python/setuptools[${PYTHON_USEDEP}]
28         >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
29         dev-python/httplib2[${PYTHON_USEDEP}]
30         dev-python/six[${PYTHON_USEDEP}]
31         net-misc/sshpass
32         virtual/ssh
33 "
34 DEPEND="
35         dev-python/setuptools[${PYTHON_USEDEP}]
36         test? (
37                 ${RDEPEND}
38                 dev-python/nose[${PYTHON_USEDEP}]
39                 >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
40                 <dev-python/mock-1.1[${PYTHON_USEDEP}]
41                 dev-python/passlib[${PYTHON_USEDEP}]
42                 dev-python/coverage[${PYTHON_USEDEP}]
43                 dev-python/unittest2[${PYTHON_USEDEP}]
44                 dev-vcs/git
45         )"
46
47 python_test() {
48         nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
49 }
50
51 python_compile_all() {
52         local _man
53         for _man in ansible{,-{galaxy,playbook,pull,vault}}; do
54                 a2x -f manpage docs/man/man1/${_man}.1.asciidoc.in || die "Failed generating man page (${_man})"
55         done
56 }
57
58 python_install_all() {
59         EXAMPLES=( examples )
60         distutils-r1_python_install_all
61
62         doman docs/man/man1/*.1
63 }