Drop $Id$ per council decision in bug #611234.
[gentoo.git] / app-admin / ansible / ansible-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1 eutils git-r3
9
10 DESCRIPTION="Model-driven deployment, config management, and command execution framework"
11 HOMEPAGE="http://ansible.com/"
12 # the version here is special because upstream did a 2.0.0 release on accident one time...
13 EGIT_REPO_URI="git://github.com/ansible/ansible.git"
14 EGIT_BRANCH="devel"
15
16 LICENSE="GPL-3"
17 SLOT="0"
18 KEYWORDS=""
19 IUSE="keyczar test"
20
21 RDEPEND="
22         keyczar? ( dev-python/keyczar[${PYTHON_USEDEP}] )
23         dev-python/paramiko[${PYTHON_USEDEP}]
24         dev-python/jinja[${PYTHON_USEDEP}]
25         dev-python/pyyaml[${PYTHON_USEDEP}]
26         dev-python/setuptools[${PYTHON_USEDEP}]
27         >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
28         dev-python/httplib2[${PYTHON_USEDEP}]
29         dev-python/six[${PYTHON_USEDEP}]
30         app-text/asciidoc
31         net-misc/sshpass
32         virtual/ssh
33 "
34 DEPEND="
35         dev-python/setuptools[${PYTHON_USEDEP}]
36         >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
37         test? (
38                 ${RDEPEND}
39                 dev-python/nose[${PYTHON_USEDEP}]
40                 >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
41                 <dev-python/mock-1.1[${PYTHON_USEDEP}]
42                 dev-python/passlib[${PYTHON_USEDEP}]
43                 dev-python/coverage[${PYTHON_USEDEP}]
44                 dev-python/unittest2[${PYTHON_USEDEP}]
45                 dev-vcs/git
46         )"
47
48 python_test() {
49         nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
50 }
51
52 python_compile_all() {
53         local _man
54         for _man in ansible{,-{galaxy,playbook,pull,vault}}; do
55                 a2x -f manpage docs/man/man1/${_man}.1.asciidoc.in || die "Failed generating man page (${_man})"
56         done
57 }
58
59 python_install_all() {
60         EXAMPLES=( examples )
61         distutils-r1_python_install_all
62
63         doman docs/man/man1/*.1
64 }